• Warp4 und NetWare Client 2.12

    From Anna Christina Nass@2:240/5824.1 to Alle on Sun Jul 4 16:24:00 2021
    Hallo,

    ich versuche gerade, auf einem Pentium 233 OS/2 Warp 4 zu installieren.
    Dazu habe ich mit meiner Warp4-CD begonnen und anschlieáend per CSF
    (von einer Zip-Diskette aus) FP15 und DDK2 installiert.

    Als Netzwerkkarte ist eine 3Com-PCI-Karte installiert, die per 3C90X-
    Treiber auch grunds„tzlich funktioniert.

    Bei der Installation habe ich die Karte konfiguriert und die Clients fr Samba (LAN Requester), TCP/IP und NetWare ausgew„hlt.
    Als Protokolle sind TCP/IP, NetBIOS ber TCP/IP und NetWare-Untersttzung (IPX/SPX) ausgew„hlt. Bei IPX/SPX habe ich Ethernet_II als Frame gew„hlt,
    da mein NetWare 4.11-Server dieses nutzt.

    Direkt nach der Installation lief alles einwandfrei, ich habe auch schon
    das LOGIN-Laufwerk vom NetWare-Server gesehen, auch TCP/IP funktionierte (ping heise.de z.B.). Samba hatte ich noch nicht getestet.

    Beim Installieren aller Updates habe ich auch den NetWare-Client 2.12 installiert, allerdings ging danach das Netzwerk nicht mehr richtig, inzwischen bin ich soweit, daá beim Booten der 3Com-Treiber (ich glaub,
    der ODI-Treiber) startet und das System dann einfriert.

    Daher meine Frage: Hat hier jemand Erfahrungen mit dem NetWare-Client 2.12
    in Kombination mit dem Rest, idealerweise mit einer 3Com-Karte? :)

    Wenn ich das richtig verstanden habe, muá man ja entweder einen ODI- oder NDIS-Treiber verwenden und dann per weiterer Schicht (ODINSUP, LANSUP?)
    das jeweils andere System untersttzen, richtig?

    Dankesch”n!

    Viele Gráe
    Anna

    --- OpenXP 5.0.50
    * Origin: Imzadi Box Point (2:240/5824.1)
  • From Harald Grosch@2:240/4075 to Anna Christina Nass on Sun Jul 4 20:32:14 2021
    Anna Christina Nass wrote to Alle:
    Hallo,
    NDIS-Treiber verwenden und dann per weiterer Schicht (ODINSUP, LANSUP?) das jeweils andere System unterstützen, richtig?

    Guten Abend Anna Christina,

    du solltest hier den NDIS-Treiber verwenden, er wurde fuer
    3Com-Netzwerk-Karten entwickelt.

    Gruss
    Harald




    ...

    --- MBSE BBS v1.0.7.22 (GNU/Linux-x86_64)
    * Origin: Ninive_BBS, Pegnitz, Oberfranken, Germany (2:240/4075)
  • From Anna Christina Nass@2:240/5824.1 to Harald Grosch on Mon Jul 5 11:40:00 2021
    Am 04.07.21 schrieb Harald Grosch@2:240/4075 in OS2.GER:

    Hallo Harald,

    NDIS-Treiber verwenden und dann per weiterer Schicht (ODINSUP, LANSUP?) ACN>> das jeweils andere System unterstuetzen, richtig?

    du solltest hier den NDIS-Treiber verwenden, er wurde fuer 3Com-Netzwerk-Karten entwickelt.

    Danke. Ich hab das so aehnlich auch in der NetWare-FAQ gefunden und werde
    das mal probieren.
    Ich muss mich da jetzt erst mal wieder reinfuchsen, meine letzten "echten" OS/2-Erfahrungen sind ja auch so ~20 Jahre alt...

    Viele Gruesse
    Anna

    --- OpenXP 5.0.50
    * Origin: Imzadi Box Point (2:240/5824.1)
  • From Torsten Bamberg@2:240/5832 to Anna Christina Nass on Tue Jul 6 02:24:26 2021
    Hallo Anna!

    05.07.2021 11:40, Anna Christina Nass schrieb an Harald Grosch:

    NDIS-Treiber verwenden und dann per weiterer Schicht (ODINSUP,
    LANSUP?) das jeweils andere System unterstuetzen, richtig?
    du solltest hier den NDIS-Treiber verwenden, er wurde fuer
    3Com-Netzwerk-Karten entwickelt.
    Danke. Ich hab das so aehnlich auch in der NetWare-FAQ gefunden und
    werde das mal probieren. Ich muss mich da jetzt erst mal wieder reinfuchsen, meine letzten "echten" OS/2-Erfahrungen sind ja auch so
    ~20 Jahre alt...
    Auch die 3Com NDIS Treiber waren nie richtig stabil. Die Intel EtherNic-NDIS-Treiber nebst des Lan Requesters unter Warp4/4.5 schon.
    Bei der Steinzeitmaschine (P233) wrde ich ich auf Intel EtherNic setzen.

    Hier laufen heute unter ECS 2.1 patched SMP auch nur Intel EtherNic, allerdings habe ich keinen Novell Server 3+xxx sondern aller Mounts laufen via SMBFS auf FreeBSD12 SMBFS.

    Bezglich Novell Server ist Olav Rogall hier eigentlich noch aktiv, allerdings hat er seite gut einem jahr das problem, eben seine alte Warp4.x geschichte zum laufen zu bekommen.

    Novell ist afaik bereits in den 1980ern tot. daher auch die fehlende Untersttzung durch die Warp 4/5.

    Viele Gruesse
    Anna
    Bye/2 Torsten

    ... MAILBOX01: up 6d 1h 31m load: 39 proc, 171 threads (tbup1.1)
    --- GoldED+ 1.1.5-19
    * Origin: DatenBahn BBS Hamburg (2:240/5832)
  • From Bernhard Thoben@2:240/9190 to Anna Christina Nass on Tue Jul 6 15:31:38 2021
    Moin Anna!

    Am 04.07.2021 um 16:24 schrieb Anna Christina Nass an Alle Folgendes:

    NetBIOS ber TCP/IP

    Direkt wieder entfernen!


    Und weg... Bernhard

    ... MAILBOX: Uptime is 196d 04h 00m 43s (BT-Uptime/OS2, V1.5)
    --- GoldED+/EMX 1.1.5-b20160827
    * Origin: Kein Gag: Das ist das Ende dieser Mail! (2:240/9190)
  • From Anna Christina Nass@2:240/5824.1 to Torsten Bamberg on Wed Jul 7 09:51:00 2021
    Am 06.07.21 schrieb Torsten Bamberg@2:240/5832 in OS2.GER:

    Hallo Torsten,

    Auch die 3Com NDIS Treiber waren nie richtig stabil. Die Intel EtherNic-NDIS-Treiber nebst des Lan Requesters unter Warp4/4.5 schon. Bei der Steinzeitmaschine (P233) wrde ich ich auf Intel EtherNic setzen.

    Okay :)
    Ich hab in der Steckkarten-Kiste noch eine Intel-Karte mit 100 MBit/s gefunden, die werd ich mal ausprobieren.

    Hier laufen heute unter ECS 2.1 patched SMP auch nur Intel EtherNic, allerdings habe ich keinen Novell Server 3+xxx sondern aller Mounts laufen via SMBFS auf FreeBSD12 SMBFS.

    Ich hab beides, einmal mein "normales" NAS, auf dem Samba l„uft, aber eben -aus sentimentalen Grnden- seit kurzem auch noch ein NetWare 4.11 aufgesetzt.
    Mit NetWare bin ich ca. 1995 in die "ernsthafte" EDV eingestiegen, als ich
    im Team dabei war, welches an meiner damaligen Schule das erste LAN
    aufgebaut hat.

    Novell ist afaik bereits in den 1980ern tot. daher auch die fehlende Untersttzung durch die Warp 4/5.

    Meiner Ansicht nach ist Novell so Mitte/Ende der 90er gestorben, als sie (leider) den Anschluá bei Win9x und NT verloren haben und sich auch z.B.
    mit verschiedenen Experimenten in der Art der Administration verlaufen
    haben.
    Und da OS/2 so ab ungef„hr der gleichen Zeit auch (leider) auf dem absteigenden Ast war, gab es halt keine groáe Untersttzung mehr.

    Viele Gráe
    Anna

    --- OpenXP 5.0.50
    * Origin: Imzadi Box Point (2:240/5824.1)
  • From Anna Christina Nass@2:240/5824.1 to Bernhard Thoben on Wed Jul 7 09:51:00 2021
    Am 06.07.21 schrieb Bernhard Thoben@2:240/9190 in OS2.GER:

    Hallo Bernhard,

    NetBIOS ber TCP/IP
    Direkt wieder entfernen!

    Kannst Du das etwas weiter ausfhren - wird das nicht fr Samba-Freigaben gebraucht?

    Viele Gráe
    Anna

    --- OpenXP 5.0.50
    * Origin: Imzadi Box Point (2:240/5824.1)
  • From Bernhard Thoben@2:240/9190 to Anna Christina Nass on Wed Jul 7 13:03:44 2021
    Moin Anna!

    Am 07.07.2021 um 09:51 schrieb Anna Christina Nass an Bernhard Thoben Folgendes:

    NetBIOS ber TCP/IP
    Direkt wieder entfernen!

    Kannst Du das etwas weiter ausfhren - wird das nicht fr
    Samba-Freigaben gebraucht?

    Da ich meine OS/2 (genauer: eCS 2.1) Kiste als Server betreibe, ben”tige ich es nicht!

    Und soweit ich mich erinnere, muá das auch entfernt werden, wenn man ein "neueres" TCP/IP Paket installiert.

    Da das aber schon so lange her ist, ist das alles ohne Gew„hr...


    Und weg... Bernhard

    ... MAILBOX: Uptime is 197d 01h 33m 58s (BT-Uptime/OS2, V1.5)
    --- GoldED+/EMX 1.1.5-b20160827
    * Origin: Berni's Box: Nie fragen, selber anrufen! (2:240/9190)
  • From Torsten Bamberg@2:240/5832 to Bernhard Thoben on Thu Jul 8 01:32:29 2021
    Hallo Bernhard!

    07.07.2021 13:03, Bernhard Thoben schrieb an Anna Christina Nass:

    NetBIOS ber TCP/IP
    Direkt wieder entfernen!
    !

    Kannst Du das etwas weiter ausfhren - wird das nicht fr
    Samba-Freigaben gebraucht?

    Da ich meine OS/2 (genauer: eCS 2.1) Kiste als Server betreibe,
    ben”tige ich es nicht!

    Und soweit ich mich erinnere, muá das auch entfernt werden, wenn man
    ein "neueres" TCP/IP Paket installiert.

    Da das aber schon so lange her ist, ist das alles ohne Gew„hr...
    Nicht ohne Gew„hr, sondern bereits die IBM-Peers Faq in den 1990ern empfahl tcp/ip ber netbios zu deaktivieren. Thomas Waldmann hatte seinerzeit mit den Seiten 'OS/2 Peers FAQ' dies auch begrndet.

    ASAIK gilt dies fr den SMP-Kernel, also Warp 4.5 und h”her.

    Auf meinen alten Internetseiten unter http://datenbahn.dd-dns.de/howto/os2 habe ich ein paar infos der PeerFaq von Thomas Waldmann erhalten.

    Und weg... Bernhard
    Bye/2 Torsten

    ... MAILBOX01: up 8d 0h 43m load: 39 proc, 171 threads (tbup1.1)
    --- GoldED+ 1.1.5-19
    * Origin: DatenBahn BBS Hamburg (2:240/5832)
  • From Bernhard Thoben@2:240/9190 to Torsten Bamberg on Fri Jul 9 12:03:32 2021
    Moin Torsten!

    Am 08.07.2021 um 01:32 schrieb Torsten Bamberg an Bernhard Thoben Folgendes:

    NetBIOS ber TCP/IP
    Direkt wieder entfernen!
    !

    Danke! Auch fr die Erl„uterungen, die ich hier nicht zitiert habe.


    Und weg... Bernhard

    ... MAILBOX: Uptime is 199d 00h 29m 35s (BT-Uptime/OS2, V1.5)
    --- GoldED+/EMX 1.1.5-b20160827
    * Origin: Windows: Tested, laughed, deleted! (2:240/9190)
  • From Harald Kamm@2:2490/3045 to Torsten Bamberg on Sat Jul 17 06:33:12 2021
    Ciao Torsten,

    Replying to a message of Torsten Bamberg to Bernhard Thoben:

    Nicht ohne Gewähr, sondern bereits die IBM-Peers Faq in den 1990ern empfahl tcp/ip über netbios zu deaktivieren. Thomas Waldmann hatte seinerzeit mit den Seiten 'OS/2 Peers FAQ' dies auch begründet.

    Afair war Thomas Baumann der Verfasser ;-)

    Liegt auch im GFD unter

    PEERF0OS.ZIP 2100K 05.01.00 PEER-Netzwerk-FAQ (OS/2 INF FORMAT) Buch 0
    bis 5 ,7 ver 1.1.1 (3.1.2000)


    Servus, Harald!

    --- FleetStreet 1.27.3.8d
    * Origin: ... (2:2490/3045)
  • From Anna Christina Nass@2:240/5824.1 to Harald Kamm on Tue Jul 20 13:52:00 2021
    Am 17.07.21 schrieb Harald Kamm@2:2490/3045 in OS2.GER:

    Hallo Harald,

    Nicht ohne Gew„hr, sondern bereits die IBM-Peers Faq in den 1990ern
    empfahl tcp/ip ber netbios zu deaktivieren. Thomas Waldmann hatte
    seinerzeit mit den Seiten 'OS/2 Peers FAQ' dies auch begrndet.

    Afair war Thomas Baumann der Verfasser ;-)
    Liegt auch im GFD unter
    PEERF0OS.ZIP 2100K 05.01.00 PEER-Netzwerk-FAQ (OS/2 INF FORMAT)
    Buch 0 bis 5 ,7 ver 1.1.1 (3.1.2000)

    Dankesch”n fr den Hinweis.
    Hab mir die Datei mal bei Torsten geholt und schau sie mir n„her an.

    (Da ich gerade das Netzteil des Rechners, auf dem OS/2 laufen wird,
    erneuere, geht das alles etwas langsam voran im Moment. Eilt aber ja auch nicht :))

    Viele Gráe
    Anna

    --- OpenXP 5.0.50
    * Origin: Imzadi Box Point (2:240/5824.1)
  • From Kai Richter@2:240/77 to Anna Christina Nass on Wed Jul 21 00:58:12 2021
    Grüß Dich, Anna!

    Am 20 Jul 21, Anna Christina Nass schrieb an Harald Kamm:

    (Da ich gerade das Netzteil des Rechners, auf dem OS/2 laufen wird, erneuere, geht das alles etwas langsam voran im Moment.

    Seufz, handgewickelte Trafos im Netzteil, das waren noch Zeiten...

    Tschuess

    Kai

    --- GoldED+/LNX 1.1.4.7
    * Origin: OS/2 or Linux, that is the question here (2:240/77)
  • From Anna Christina Nass@2:240/5824.1 to Kai Richter on Wed Jul 21 17:54:00 2021
    Am 21.07.21 schrieb Kai Richter@2:240/77 in OS2.GER:

    Hallo Kai,

    (Da ich gerade das Netzteil des Rechners, auf dem OS/2 laufen wird,
    erneuere, geht das alles etwas langsam voran im Moment.

    Seufz, handgewickelte Trafos im Netzteil, das waren noch Zeiten...

    ;-) In Ermangelung einer elektrotechnischen Ausbildung traue ich mir
    *sowas* definitiv nicht zu.
    Ich habe es so gemacht: Ein 12V-Netzteil (72W), daran ein PicoPSU-Modul
    und ein ATX-AT-Adapter, der auch noch -5V erzeugt und auch den Ein/Aus- Schalter weiter nutzen l„át.
    Das alles kommt jetzt in einen 3D-gedruckten Rahmen, der an Stelle des bisherigen Netzteils eingebaut wird und auch einen Noctua-Lfter hat.

    Bisher hat der Rechner ca. 55W verbraucht, also hoffe ich einfach, daá das auch jetzt reicht :)

    Viele Gráe
    Anna

    --- OpenXP 5.0.50
    * Origin: Imzadi Box Point (2:240/5824.1)
  • From Torsten Bamberg@2:240/5832 to Anna Christina Nass on Sat Jul 24 01:02:01 2021
    Hallo Anna!

    21.07.2021 17:54, Anna Christina Nass schrieb an Kai Richter:

    Seufz, handgewickelte Trafos im Netzteil, das waren noch Zeiten...
    ;-) In Ermangelung einer elektrotechnischen Ausbildung traue ich mir *sowas* definitiv nicht zu.
    Auch gelernte Elektroniker haben selten einen Trafo gewickelt. ;-)
    Meinen letzten Trafo habe ich in der Ausbildung 1985 gewickelt. Danach habe ich alle Trafos gekauft. Die Arbeit, einen sauberen brummfreien Trafo selber zu wickeln ist unfassbar komplex, zudem es eine Arbeit fr jemanden ist, der eine unglaublich hohe Geduld aufbringen muá.

    Ich habe es so gemacht: Ein 12V-Netzteil (72W), daran ein
    PicoPSU-Modul und ein ATX-AT-Adapter, der auch noch -5V erzeugt und
    auch den Ein/Aus- Schalter weiter nutzen l„át. Das alles kommt jetzt
    in einen 3D-gedruckten Rahmen, der an Stelle des bisherigen Netzteils eingebaut wird und auch einen Noctua-Lfter hat.
    Ich nehme, insofern es sich um Rechnertechnik handelt, immer gern die TFX-Netzteile von 'be quiet!'. Relativ preisgnstig, und mit 80+ auch energiesparend unter Last. Damit spare ich mir Adapter auf Adapter auf Adapter.

    Bisher hat der Rechner ca. 55W verbraucht, also hoffe ich einfach, daá
    das auch jetzt reicht :)
    Auf den Webseiten von 'be quiet!' gibt es einen recht guten 'Netzteil-Kalkulator', damit kann recht gut die Nutzlast bestimmt werden.

    Bei analoger Technik, und auch Audiotechnik trenne ich die Spannungsversorgung auf. Audiotechnik wird mit konventionellen Trafo/Gleichrichter/Siebung versorgt, Rechnertechnik ber Schaltnetzteile. Der Grund ist einfach; Schaltnetzteile verursachen auch mit guter Siebung der Versorgungsspannung immer ein 'Zirpen', 'Knatschen' oder auch 'Quicken' bei der Audioausgabe.


    BTW: IPX vertr„gt sich nicht mit dem Tcp/ip Stack unter der Warp4/4.x auf dem gleichem Netzwerkadapter.
    Seinerzeit mit Novel Light hatte ich genau dieses Problem. Die einzige L”sung war, tcp/ip auf Adapter 0 (Intel Etherreal) und IPX auf Adapter 1 (3Com) zu aktivieren. Allerdings ist das Bridging nicht ganz trivial, sodass ich nach einigem herumexpermentiern IPX nebst der 3Com Karte deaktiviert und ausgebaut, und Novel Light zugunsten von FreeBSD smbfs mit den ndfs-Treibern umgestellt hatte. In meinen alten Doks habe ich dies dokumentiert gehabt. Beim Lesen in den letzten Tagen ist mir dies dann eingefallen. Ist ja auch ein paar Jahre her. ;-)

    Viele Gráe
    Anna
    Bye/2 Torsten

    ... MAILBOX01: up 24d 0h 04m load: 40 proc, 195 threads (tbup1.1)
    --- GoldED+ 1.1.5-19
    * Origin: DatenBahn BBS Hamburg (2:240/5832)
  • From Anna Christina Nass@2:240/5824.1 to Torsten Bamberg on Sun Aug 1 15:57:00 2021
    Am 24.07.21 schrieb Torsten Bamberg@2:240/5832 in OS2.GER:

    Hallo Torsten,

    ;-) In Ermangelung einer elektrotechnischen Ausbildung traue ich mir
    *sowas* definitiv nicht zu.
    Auch gelernte Elektroniker haben selten einen Trafo gewickelt. ;-)

    Na dann :)

    Meinen letzten Trafo habe ich in der Ausbildung 1985 gewickelt. Danach
    habe ich alle Trafos gekauft. Die Arbeit, einen sauberen brummfreien Trafo selber zu wickeln ist unfassbar komplex, zudem es eine Arbeit fr jemanden ist, der eine unglaublich hohe Geduld aufbringen muá.

    Kann ich mir vorstellen.

    Ich nehme, insofern es sich um Rechnertechnik handelt, immer gern die TFX-Netzteile von 'be quiet!'. Relativ preisgnstig, und mit 80+ auch energiesparend unter Last. Damit spare ich mir Adapter auf Adapter auf Adapter.

    Wohl wahr. In meinem Fall ging es aber darum, ein AT-Mainboard (ohne ATX- Anschluá) in einem AT-Geh„use zum Laufen zu kriegen.

    Und nach etwas Frust und Arbeit hat es jetzt auch geklappt, der Rechner
    l„uft wieder.
    Es sind jetzt drei Teile an der Stromerzeugung bzw. -wandlung beteiligt:
    - 72W-Netzteil fr +12V
    - picoPSU mit ATX-Ausgang fr alle m”glichen Spannungen
    - AT-Adapter fr -5V und Nutzung des alten Power-Schalters

    Bei der picoPSU hat die 90W-Version wohl doch nicht gereicht, da dann die Nutzung von CD-ROM-Laufwerk und Soundkarte gleichzeitig nicht klappte.
    Ich habe jetzt eine gr”áere picoPSU eingebaut und jetzt l„uft es, interessanterweise auch immer noch mit dem 72W-Netzteil dahinter.

    Ich werde noch etwas beobachten, ob es Instabilit„ten gibt... :)

    Bisher hat der Rechner ca. 55W verbraucht, also hoffe ich einfach,
    daá das auch jetzt reicht :)
    Auf den Webseiten von 'be quiet!' gibt es einen recht guten 'Netzteil- Kalkulator', damit kann recht gut die Nutzlast bestimmt werden.

    Hab ich mal angeschaut: Pentium-233, Matrox Millennium II oder NEC Zip- Laufwerk sind leider nicht in der Liste... :-(

    BTW: IPX vertr„gt sich nicht mit dem Tcp/ip Stack unter der Warp4/4.x
    auf dem gleichem Netzwerkadapter.

    Ooookay...?! Inwiefern zeigt sich die Inkompatibilit„t?
    Ist dafr aber nicht eigentlich genau der MPTS, der ja irgendwas mit "Multi-Protocol..." heiát, da?

    Und zumindest mit der Version des NetWare-Clients, der mit Warp4
    ausgeliefert wird, hat der Zugriff auf den NetWare-Server und auch TCP/IP geklappt... Und das war sogar noch mit der 3Com-Karte.

    Ich hab jetzt eine Intel "irgendwas" PRO/100 S drin, das muá ich jetzt
    unter OS/2 noch einrichten. Hab den Rechner erst heute wieder zusammengeschraubt :)

    Seinerzeit mit Novel Light hatte ich genau dieses Problem.

    NetWare Light ist ja meines Wissens nach eh nochmal ne andere Geschichte
    als NetWare "ohne light". Damit habe ich auch keine Erfahrung.

    Viele Gráe
    Anna

    --- OpenXP 5.0.50
    * Origin: Imzadi Box Point (2:240/5824.1)