• DHCP Protokoll - incompatibler standard??

    From Kai Richter@2:240/77 to Alle on Mon Sep 4 12:03:40 2023
    Hallo!

    Gibt es Veränderungen beim DHCP Protokoll?

    Mein WLAN Router bekommt vom Kabelmodem nur eine IPv4 per dhcp zugewiesen,

    Nun wurde Dual Stack aktiviert, in der Modem Info sehe ich eine IPv4 und eine IPv6, aber der WLAN Router trägt keine IPv6 ein.

    Das Interface des WLAN Routers habe ich per ssh auf aktives IPv6 geprüft, sowohl die Bridge eth0 als auch der WAN eth0.2 haben eine IPv6.

    netstat -r liefert jedoch nur IPv4 angaben.

    Das Problem trat erst nach einem selbstständigen Reboot des Kabelmodem auf.

    Ich brauche keine IPv6, aber dieses Problem wurde bei anderer Fehlersuche sichtbar (Gateway nicht erreichbar). Daher möchte ich Probleme auf meiner Seite möglichst ausschliessen.

    Tschuess

    Kai

    --- GoldED+/LNX 1.1.4.7
    * Origin: Geld verdienen heisst: Lebensenergie eintauschen. (2:240/77)
  • From Gerhard Strangar@2:240/2188.575 to Kai Richter on Mon Sep 4 19:20:11 2023
    Am 04 Sep 23 12:03:40 schrob Kai Richter an Alle zum Thema
    <DHCP Protokoll - incompatibler standard??>

    Mein WLAN Router bekommt vom Kabelmodem nur eine IPv4 per dhcp
    zugewiesen,

    Vodafone-Station? Da bekommst Du im Bridge-Mode eine echte IPv4-Adresse und sonst DS Lite.



    Tschoe mit Oe
    Gerhard
    ---
    * Origin: (2:240/2188.575)
  • From Kai Richter@2:240/77 to Gerhard Strangar on Tue Sep 5 00:16:06 2023
    Tach Gerhard!

    Am 04 Sep 23, Gerhard Strangar schrieb an Kai Richter:

    Mein WLAN Router bekommt vom Kabelmodem nur eine IPv4 per dhcp
    zugewiesen,

    Vodafone-Station?

    Nein, Connect Box compal CH7465...

    Da bekommst Du im Bridge-Mode eine echte IPv4-Adresse

    Die hatte ich ja vorher mit der Connect Box.
    Aber seit dem Ausfall am 29.8. geht ja genau das nicht mehr.
    Auf meiner Seite wurde da nichts verändert.

    Die Vodafone Station ist nun zu mir unterwegs, aber ich habe böse Vorahnungen.

    Tschuess

    Kai

    --- GoldED+/LNX 1.1.4.7
    * Origin: Kommt darauf an. (2:240/77)
  • From Joerg Tewes@2:240/2188.96 to Kai Richter on Mon Sep 4 21:43:00 2023
    Kai Richter schrub...


    Hallo Kai,

    Gibt es Ver„nderungen beim DHCP Protokoll?

    Mein WLAN Router bekommt vom Kabelmodem nur eine IPv4 per dhcp
    zugewiesen,

    HAst du im WLAN-Router IPv6 aktiviert? Standardm„áig ist es in der
    Fritz!Box n„mlich deaktiviert.

    Nun wurde Dual Stack aktiviert, in der Modem Info sehe ich eine
    IPv4 und eine IPv6, aber der WLAN Router tr„gt keine IPv6 ein.

    Das Interface des WLAN Routers habe ich per ssh auf aktives IPv6
    geprft, sowohl die Bridge eth0 als auch der WAN eth0.2 haben eine
    IPv6.

    Ahja vergiá obige Frage.

    netstat -r liefert jedoch nur IPv4 angaben.

    Schlieá mal einen PC an das Kabelmodem an, ob der eine IPv6 bekommt.



    Freundliche Gráe

    J”rg

    --- OpenXP 5.0.56
    * Origin: Trust no One (2:240/2188.96)
  • From Kai Richter@2:240/77 to Joerg Tewes on Thu Sep 7 12:26:28 2023
    Hallo Joerg!

    Am 04 Sep 23, Joerg Tewes schrieb an Kai Richter:

    Gibt es Veränderungen beim DHCP Protokoll?

    Mein WLAN Router bekommt vom Kabelmodem nur eine IPv4 per dhcp
    zugewiesen,

    HAst du im WLAN-Router IPv6 aktiviert? Standardmäßig ist es in der Fritz!Box nämlich deaktiviert.

    Es ist ein OpenWRT und IPv6 wurde von mir nicht gezielt abgeschaltet, der Haken ist aktiv bei "use builtin IPv6-management". In der Übereicht wird v4 und v6 upstream getrennt angezeigt (aktuell beides ohne Eintrag) und ich meine bei v6 stand auch irgendwann mal etwas.

    netstat -r liefert jedoch nur IPv4 angaben.

    Schließ mal einen PC an das Kabelmodem an, ob der eine IPv6 bekommt.

    Da bin ich eingeschränkt und müsste schleppen. Ich komme einen alten 32bit Laptop an das Kabelmodem, mit WinXP. ;-)

    Aber das zeigt eine IPv4 in der GUI und per ipconfig ebenfalls an der LAN Verbindung, aber da ist auf einmal ein Tunneladapter 6to4 Adapter mit einer IPv6 Addresse und einem IPv6 Standard Gateway.

    Inzwischen wurde das Kabelmodem getauscht.
    Die Vodafone Station bietet ebenfalls in ihrer GUI einen Bridge Mode.
    Wenn ich den einschalte, bekommt mein WLAN Router wieder eine v4 noch v6 vom dhcpd.

    Trage ich die IPs die ich in der WinXP GUI gesehen habe als statische IP ein, funktioniert das leider auch nicht.

    Tschuess

    Kai

    --- GoldED+/LNX 1.1.4.7
    * Origin: Das kommt immer darauf an. (2:240/77)
  • From Michiel van der Vlist@2:280/5555 to Kai Richter on Fri Sep 8 09:06:07 2023
    Tag Kai,

    Am Donnerstag 07 September 2023 12:26 schrieb Kai Richter an Joerg Tewes:

    Schließ mal einen PC an das Kabelmodem an, ob der eine IPv6
    bekommt.

    Da bin ich eingeschränkt und müsste schleppen. Ich komme einen alten
    32bit Laptop an das Kabelmodem, mit WinXP. ;-)

    WinXP macht IPv6 aber nicht by default. Es muß expliciet eingeschaltet werden:

    ipv6 install


    Grüße, Michiel

    --- GoldED+/W32-MSVC 1.1.5-b20170303
    * Origin: http://www.vlist.eu (2:280/5555)
  • From Kai Richter@2:240/77 to Joerg Tewes on Mon Sep 11 18:15:22 2023
    Tach Joerg!

    Am 07 Sep 23, Kai Richter schrieb an Joerg Tewes:

    Schließ mal einen PC an das Kabelmodem an, ob der eine IPv6
    bekommt.

    Da bin ich eingeschränkt und müsste schleppen. Ich komme einen alten
    32bit Laptop an das Kabelmodem, mit WinXP. ;-)

    Ich habe jetzt eine Porteus 5.0 auf dem 32bit Laptop laufen und direkt am Kabelmodem angeschlossen. Diese bekommt per default eine IPv4 178.xxx und eine IPv6 2a02:xxx.

    ABER ich konnte nicht heraus finden, welcher default für Porteus 5.0 bei der dhcp option 60 (Vendor Class Identifier) gesetzt ist.

    Die /etc/dhclient.conf ist jedenfalls leer.

    Tschuess

    Kai

    --- GoldED+/LNX 1.1.4.7
    * Origin: How you treat otherss, treated you'll be! (2:240/77)
  • From Kai Richter@2:240/77 to Alle on Tue Sep 12 01:12:06 2023
    Tach auch Alle!

    Am 04 Sep 23, Kai Richter schrieb an Alle:

    Fehlersuche sichtbar (Gateway nicht erreichbar). Daher möchte ich
    Probleme auf meiner Seite möglichst ausschliessen.

    Das Problem ist jetzt reproduzierbar. Mein Kabelmodem bekommt im Bridge Mode nur dann ein funktionierendes Gateway, wenn der dhcp client mit der

    option 60 vendor class identifier

    ergänzt wird. Nur wenn dort mindestens ein Zeichen eingetragen wird, läuft die Bridge wie vorgesehen. Es funktioniert schon ein einzelnes Leerzeichen.

    Ich habe option 60 in RFC 2132 unter 9.13 gefunden, lese ich das richtig, dass diese Angabe optional ist?

    Tschuess

    Kai

    --- GoldED+/LNX 1.1.4.7
    * Origin: Ruhe bitte. Dummkoepfe! Es leben nur noch die Idioten. (2:240/77)